0%

Ubuntu下 Apache2在home目录下创建虚拟主机提示403

今天公司要开展一个新项目,要在服务器内创建一个虚拟服务器test
我将目录设置在了/var/www/之外的地方 /home/test下
配置好 test.conf文件,具体操作请参考 ubuntu apache2 如何绑定多个域名

输入地址测试的时候提示403权限问题,我修改了相应的目录权限,还是失败。
在网上查资料的时候发现,Apache2只允许/var/www、/usr/share下面的文件夹被访问
所以/home/以下的目录是不允许访问的,我们只好修改/etc/apache2/apache2.conf文件
在最下面添加

1
2
3
4
5
<Directory /home/test>
Options Indexes FollowSymLinks
AllowOverride None
Require all granted
</Directory>

重启apache2服务,成功!