0%

Wordpress PHP Strict Standards:问题解决

在PHP5.3.3 中安装wordpress 3.9 ,在安装时出现错误:Strict Standards: PHP Strict Standards: Declaration of Walker…..的解决办法:

出现错误提示:Strict Standards: PHP Strict Standards: Declaration of Walker_Page::start_lvl() should be compatible with that of Walker::start_lvl() in E:\Webroot\wordpress\wp-includes\classes.php on line 1199 PHP Strict Standards: Declaration of Walker_Page::end_lvl() should be compatible with that of Walker::end_lvl() in E:\Webroot\wordpress\wp-includes\classes.php on line 1199 PHP Strict ……..
错误原因:
这是由于 php 5.3版本后。要求继承类必须在父类之后定义。否则就会出现Strict Standards: PHP Strict Standards: Declaration of …. should be compatible with that of …. 的错误提示。也就是说必须父类在前,继承类在后。
错误参考页面。bugs点php点net/bug.php?id=46851 (不能发表带链接的网址) 上面清楚地解释了出现此类错误的具体原因。
解决办法:在wordpress3.0.1 文件中,找到 wp-admin\setup-config.php 文件。在require_once('../wp-includes/compat.php'); 上面添加一句:
error_reporting(E_ALL & ~(E_STRICT | E_NOTICE));
问题解决。
这句话的意思是错误报告设置:显示所有错误,但是除了严格错检查或者错误报告。也就是说PHP5.3.3 不执行严格错误检查。也不显示错误提示。跳过严格错误检查。