0%

Ubuntu 在apache中添加虚拟机之后出现“403(禁止访问)”

如果在apache添加虚拟机之后,出现403(禁止访问)的网页,可以在httpd.conf文件中加入如下配置选项:

1
2
3
4
5
6
7
8
9
10
11
<Directory "/usr/local/httpd/htdocs/vpnbak">   这是虚拟机中的web根目录

Options Indexes FollowSymLinks

AllowOverride None (注:如果想apache支持.htaccess文件,则将AllowOverride None 改为AllowOverride ALL)

Order allow,deny

Allow from all

</Directory>

添加好之后,保存,然后重启apache机器即可。

我们把web目录放到自己的目录下面,是想不需要sudo就能修改和调整网站,但是apache2不认你的目录,因为apache2为了安全起见,只允许/var/www、/usr/share下面的文件夹被访问。所以在最后一个后面再添加上一个允许的目录就可以了。例如:

1
2
3
4
5
<Directory /home/user/websites>
Options Indexes FollowSymLinks
AllowOverride None
Require all granted
</Directory>

这样之后,再sudo service apache2 reload,就可以访问这个目录了。